Image Image Image Image Image Image Image Image Image Image
Ma kedd van, 2019. január 22. Az év 22. napja, az időszámításunk kezdete óta eltelt 737478. nap.
Lapozzon a lap tetejére

Lap tetejére

Bluetooth-sebezhetőség wifi-routerekben

Bluetooth-sebezhetőség wifi-routerekben
(Tudósítónktól)

Két biztonsági hibát fedeztek fel a rövidtávú adatátvitelre szolgáló Bluetooth Low Energy (BLE-) chipekben, amelyeket milliónyi wifi egységbe, orvosi eszközökbe építettek be. Szokás szerint a gyártók megszüntették a hibát, csakhogy nem minden használó szokta frissíteni a szoftvereket. 

A szakértők két biztonsági hibát fedeztek fel a Bluetooth Low Energy (vagyis a BLE-) chipekben, melyet szerte a világon sokmillió, vezeték nélküli internet-hozzáféréssel működő eszközben, inzulin-pumpákban, POS-terminálokon használnak. A BleedingBit néven ismertté vált sérülékenységek kihasználásával a támadóknak lehetőségük adódik az eszközön saját kódjukat futtatni, és így átvenni az irányítást az eszköz fölött. A hiba a Texas Instruments (TI) által gyártott BLE Stack chipeket érinti, ezeket a Cisco, Meraki és Aruba használja vállalati eszközökben.

Az első sérülékenység a CVE-2018-16986 kódot kapta, a CC2640 és CC2650 TI chipekben található. A hibát leíró kutatók szerint a BLE-chipben buffer-túlcsordulásos támadással előidézhető, hogy kártékony kódot lehessen az adott eszközön futtatni. A túlcsordulásos támadással memóriahibát idéznek elő.

A Bluetooth Low Energy vagy BLA-szabvány a közismert Bluetooth rövid távú adattovábbítási szabvány frissített és a modern kor szükségleteihez igazított változata. A BLE-chip sokkal kevesebb energiát használ és olcsóbb, mint a hagyományos Bluetooth-eszközök. Az első BLE-chipes okostelefon a 2011 októberében megjelent iPhone 4S készülék volt, majd 2012-ben dobták piacra a többi BLE-eszközt. A BLE-t hálózati eszközökben, főleg vezeték nélküli internet-kapcsolatra használt routerekbe, valamint orvosi eszközökbe építik be.

Vagyis: amikor a támadó a kiszemelt eszköz közelében van, előbb normális csomagokat küld a BLE-chipnek, majd elküldi a túlcsordulást okozó üzenetet is. Ezután a támadó akár távolról is átveheti az ellenőrzést az eszköz felett, például elfogja az átmenő forgalmat, hátsó ajtót telepít az eszközre vagy a hálózathoz csatolt másik eszközt támadja meg.

A második sebezhetőség, mely a CVE-2018-7080 kódnevet kapta​, a TI CC2642R2, CC2640R2, CC2640, CC2650, CC2540 és CC2541 chipjeiben található meg, és az Aruba 300-as sorozatú wifi-routereit érinti. Ezek az eszközök ugyanazokat az OAD – vagyis Over the Air Firmware Download (távoliszoftver-telepítés) – -jelszavakat használják, a támadó egy kártékony frissítést küldhet a megcélzott routerre és újra írhatja az operációs rendszerét, így átveheti az eszköz feletti ellenőrzést.

Az Armis idén júniusban fedezte fel a hibát, az érintett gyártók már kiadták a biztonsági frissítéseket. A Texas Instruments is elismerte a hiba meglétét és kiadta a javításokat, melyek az OEM-gyártókon keresztül jutnak el a végfelhasználókhoz. Ha az érintett típusú router működik hálózatunkon, ne felejtsünk el frissíteni.